const regex = /([A-Za-zΑ-Ωα-ω]{2,3}\d{1,4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-zΑ-Ωα-ω]{2,3}\\d{1,4})', '')
const str = `INTERLIFE-ΠροασφαλιστικόςΈλεγχος(ΧRΦ8985)-Λήξησυνδέσμου
([A-Za-z]{3}|[Α-Ωα-ω]{3})\\d{3,4}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}