import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-zΑ-Ωα-ω]{2,3}\\d{1,4})";
final String string = "INTERLIFE-ΠροασφαλιστικόςΈλεγχος(ΧRΦ8985)-Λήξησυνδέσμου\n"
+ "([A-Za-z]{3}|[Α-Ωα-ω]{3})\\d{3,4}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}