re = /([A-Za-zΑ-Ωα-ω]{2,3}\d{1,4})/
str = 'INTERLIFE-ΠροασφαλιστικόςΈλεγχος(ΧRΦ8985)-Λήξησυνδέσμου
([A-Za-z]{3}|[Α-Ωα-ω]{3})\\d{3,4}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end