$re = '/([A-Za-zΑ-Ωα-ω]{2,3}\d{1,4})/';
$str = 'INTERLIFE-ΠροασφαλιστικόςΈλεγχος(ΧRΦ8985)-Λήξησυνδέσμου
([A-Za-z]{3}|[Α-Ωα-ω]{3})\\d{3,4}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);