# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w).*?(.@.).*?(.\.\w+)/$1****$2***$3/gm;t' <<< "xyzdsdasdas@xyss.com
my_nameis@gmail.com"