import re
regex = re.compile(r"^(\w).*?(.@.).*?(.\.\w+)", flags=re.MULTILINE)
test_str = ("xyzdsdasdas@xyss.com\n"
"my_nameis@gmail.com")
subst = "$1****$2***$3"
result = regex.sub(subst, test_str)
if result:
print(result)