$re = '/^(\w).*?(.@.).*?(.\.\w+)/m';
$str = 'xyzdsdasdas@xyss.com
my_nameis@gmail.com';
$subst = "$1****$2***$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;