#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w).*?(.@.).*?(.\.\w+)"
Local $sString = "xyzdsdasdas@xyss.com" & @CRLF & _
"my_nameis@gmail.com"
Local $sSubst = "$1****$2***$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)