#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@[^@,]*\.([A-Za-z]{2})(?=,|$)"
Local $sString = "001,Francisca,Dr Jhonaci,jhonadr@abc.com,32yearsold,120.238.225.0" & @CRLF & _
"002,Lavenda,Bocina,lavenboci@banck.ac.uk,50yearsold,121.186.221.182" & @CRLF & _
"003,Laura,Eglington,elinton@python.co.jp,26yearsold,36.55.173.63" & @CRLF & _
"004,Timo,Baum,timobaum@tennis.co.cn,22yearsold,121.121.110.10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")