using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@[^@,]*\.([A-Za-z]{2})(?=,|$)";
string input = @"001,Francisca,Dr Jhonaci,jhonadr@abc.com,32yearsold,120.238.225.0
002,Lavenda,Bocina,lavenboci@banck.ac.uk,50yearsold,121.186.221.182
003,Laura,Eglington,elinton@python.co.jp,26yearsold,36.55.173.63
004,Timo,Baum,timobaum@tennis.co.cn,22yearsold,121.121.110.10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}