import Foundation
let pattern = #"@[^@,]*\.([A-Za-z]{2})(?=,|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
001,Francisca,Dr Jhonaci,jhonadr@abc.com,32yearsold,120.238.225.0
002,Lavenda,Bocina,lavenboci@banck.ac.uk,50yearsold,121.186.221.182
003,Laura,Eglington,elinton@python.co.jp,26yearsold,36.55.173.63
004,Timo,Baum,timobaum@tennis.co.cn,22yearsold,121.121.110.10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)