const regex = new RegExp('@[^@,]*\\.([A-Za-z]{2})(?=,|$)', 'gm')
const str = `001,Francisca,Dr Jhonaci,jhonadr@abc.com,32yearsold,120.238.225.0
002,Lavenda,Bocina,lavenboci@banck.ac.uk,50yearsold,121.186.221.182
003,Laura,Eglington,elinton@python.co.jp,26yearsold,36.55.173.63
004,Timo,Baum,timobaum@tennis.co.cn,22yearsold,121.121.110.10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}