use strict;
my $str = '001,Francisca,Dr Jhonaci,jhonadr@abc.com,32yearsold,120.238.225.0
002,Lavenda,Bocina,lavenboci@banck.ac.uk,50yearsold,121.186.221.182
003,Laura,Eglington,elinton@python.co.jp,26yearsold,36.55.173.63
004,Timo,Baum,timobaum@tennis.co.cn,22yearsold,121.121.110.10';
my $regex = qr/@[^@,]*\.([A-Za-z]{2})(?=,|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}