# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@[^@,]*\.([A-Za-z]{2})(?=,|$)"
test_str = ("001,Francisca,Dr Jhonaci,jhonadr@abc.com,32yearsold,120.238.225.0\n"
"002,Lavenda,Bocina,lavenboci@banck.ac.uk,50yearsold,121.186.221.182\n"
"003,Laura,Eglington,elinton@python.co.jp,26yearsold,36.55.173.63\n"
"004,Timo,Baum,timobaum@tennis.co.cn,22yearsold,121.121.110.10")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.