#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^ \* @([a-z]+).*\K(?=\r?\n^ \* @(?!\1))"
Local $sString = "/**" & @CRLF & _
" * Get Data" & @CRLF & _
" *" & @CRLF & _
" * @param null|ProductInterface $product" & @CRLF & _
" * @return string" & @CRLF & _
" * @throws LocalizedException" & @CRLF & _
" * @throws NoSuchEntityException" & @CRLF & _
" * @consumes something" & @CRLF & _
" * @param null|ProductInterface $product" & @CRLF & _
" * @return string" & @CRLF & _
" * @throws LocalizedException" & @CRLF & _
" * @throws NoSuchEntityException" & @CRLF & _
" * @consumes something" & @CRLF & _
" * @param null|ProductInterface $product" & @CRLF & _
" * @return string" & @CRLF & _
" * @throws LocalizedException" & @CRLF & _
" * @throws NoSuchEntityException" & @CRLF & _
" * @consumes something" & @CRLF & _
" */"
Local $sSubst = "\n *"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)