use strict;
my $str = '/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/';
my $regex = qr/^ \* @([a-z]+).*\K(?=\r?\n^ \* @(?!\1))/mp;
my $subst = '\\n *';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";