re = /^ \* @([a-z]+).*\K(?=\r?\n^ \* @(?!\1))/m
str = '/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/'
subst = '\\n *'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result