const regex = /^ \* @([a-z]+).*\K(?=\r?\n^ \* @(?!\1))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ \\* @([a-z]+).*\\K(?=\\r?\\n^ \\* @(?!\\1))', 'gm')
const str = `/**
* Get Data
*
* @param null|ProductInterface \$product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface \$product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface \$product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/`;
const subst = `\n *`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);