# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^ \* @([a-z]+).*\K(?=\r?\n^ \* @(?!\1))"
test_str = ("/**\n"
" * Get Data\n"
" *\n"
" * @param null|ProductInterface $product\n"
" * @return string\n"
" * @throws LocalizedException\n"
" * @throws NoSuchEntityException\n"
" * @consumes something\n"
" * @param null|ProductInterface $product\n"
" * @return string\n"
" * @throws LocalizedException\n"
" * @throws NoSuchEntityException\n"
" * @consumes something\n"
" * @param null|ProductInterface $product\n"
" * @return string\n"
" * @throws LocalizedException\n"
" * @throws NoSuchEntityException\n"
" * @consumes something\n"
" */")
subst = "\\n *"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.