$re = '/^ \* @([a-z]+).*\K(?=\r?\n^ \* @(?!\1))/m';
$str = '/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/';
$subst = "\n *";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;