import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ \\* @([a-z]+).*\\K(?=\\r?\\n^ \\* @(?!\\1))";
final String string = "/**\n"
+ " * Get Data\n"
+ " *\n"
+ " * @param null|ProductInterface $product\n"
+ " * @return string\n"
+ " * @throws LocalizedException\n"
+ " * @throws NoSuchEntityException\n"
+ " * @consumes something\n"
+ " * @param null|ProductInterface $product\n"
+ " * @return string\n"
+ " * @throws LocalizedException\n"
+ " * @throws NoSuchEntityException\n"
+ " * @consumes something\n"
+ " * @param null|ProductInterface $product\n"
+ " * @return string\n"
+ " * @throws LocalizedException\n"
+ " * @throws NoSuchEntityException\n"
+ " * @consumes something\n"
+ " */";
final String subst = "\\n *";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}