import re
regex = re.compile(r"^(/accounts-safes-registry/retrieval-api/v1/(ping|password|registry/feedback/|registry/))$", flags=re.MULTILINE)
test_str = ("/accounts-safes-registry/retrieval-api/v1/registry/\n"
"/accounts-safes-registry/retrieval-api/v1/registry/feedback/\n"
"/accounts-safes-registry/retrieval-api/v1/ping\n"
"/accounts-safes-registry/retrieval-api/v1/password")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")