re = /^(\/accounts-safes-registry\/retrieval-api\/v1\/(ping|password|registry\/feedback\/|registry\/))$/m
str = '/accounts-safes-registry/retrieval-api/v1/registry/
/accounts-safes-registry/retrieval-api/v1/registry/feedback/
/accounts-safes-registry/retrieval-api/v1/ping
/accounts-safes-registry/retrieval-api/v1/password'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end