#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*(?=,)|[^,]+$"
Local $sString = "1 - 21 Willow Court, 1192 Christchurch Road, Bournemouth, BH7 6EG"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)