using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?=,)|[^,]+$";
string substitution = @"$1 $2";
string input = @"1 - 21 Willow Court, 1192 Christchurch Road, Bournemouth, BH7 6EG";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}