re = /^.*(?=,)|[^,]+$/m
str = '1 - 21 Willow Court, 1192 Christchurch Road, Bournemouth, BH7 6EG'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result