import Foundation
let pattern = #"^.*(?=,)|[^,]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1 - 21 Willow Court, 1192 Christchurch Road, Bournemouth, BH7 6EG"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)