$re = '/^.*(?=,)|[^,]+$/m';
$str = '1 - 21 Willow Court, 1192 Christchurch Road, Bournemouth, BH7 6EG';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;