const regex = /^.*(?=,)|[^,]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?=,)|[^,]+$', 'gm')
const str = `1 - 21 Willow Court, 1192 Christchurch Road, Bournemouth, BH7 6EG`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);