use strict;
my $str = '1 - 21 Willow Court, 1192 Christchurch Road, Bournemouth, BH7 6EG';
my $regex = qr/^.*(?=,)|[^,]+$/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";