using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfirst(?!\))|(?<!\()first";
string input = @"The string (first) precedes first later on
The string (first precedes first later on
The string (first) precedes first later on and first again
The string (first) is not followed by another f*i*r*s*t
The string (first) precedes firstly later on
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}