re = /\bfirst(?!\))|(?<!\()first/
str = 'The string (first) precedes first later on
The string (first precedes first later on
The string (first) precedes first later on and first again
The string (first) is not followed by another f*i*r*s*t
The string (first) precedes firstly later on
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end