use strict;
my $str = 'The string (first) precedes first later on
The string (first precedes first later on
The string (first) precedes first later on and first again
The string (first) is not followed by another f*i*r*s*t
The string (first) precedes firstly later on
';
my $regex = qr/\bfirst(?!\))|(?<!\()first/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}