import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfirst(?!\\))|(?<!\\()first";
final String string = "The string (first) precedes first later on\n"
+ "The string (first precedes first later on\n"
+ "The string (first) precedes first later on and first again\n"
+ "The string (first) is not followed by another f*i*r*s*t\n"
+ "The string (first) precedes firstly later on\n\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}