$re = '/\bfirst(?!\))|(?<!\()first/';
$str = 'The string (first) precedes first later on
The string (first precedes first later on
The string (first) precedes first later on and first again
The string (first) is not followed by another f*i*r*s*t
The string (first) precedes firstly later on
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);