import re
regex = re.compile(r"\bfirst(?!\))|(?<!\()first")
test_str = ("The string (first) precedes first later on\n"
"The string (first precedes first later on\n"
"The string (first) precedes first later on and first again\n"
"The string (first) is not followed by another f*i*r*s*t\n"
"The string (first) precedes firstly later on\n\n\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")