const regex = /\bfirst(?!\))|(?<!\()first/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfirst(?!\\))|(?<!\\()first', 'g')
const str = `The string (first) precedes first later on
The string (first precedes first later on
The string (first) precedes first later on and first again
The string (first) is not followed by another f*i*r*s*t
The string (first) precedes firstly later on
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}