import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+|00)?(?:30)?(69\\d{8})";
final String string = "The mobile phone format i want to extract is 69xxxxxxxx\n"
+ "The mobile phone formats i come across in the CVs are:\n"
+ "6900000000\n"
+ "00306900000000\n"
+ "+306900000000\n"
+ "6900000000\n"
+ "69 xxx xxxxx\n"
+ "0030 69xxxxxxxx\n"
+ "+3069xxxxxxxx\n"
+ "69/xxxx/xxxx";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}