const regex = new RegExp('(?:\\+|00)?(?:30)?(69\\d{8})', 'gm')
const str = `The mobile phone format i want to extract is 69xxxxxxxx
The mobile phone formats i come across in the CVs are:
6900000000
00306900000000
+306900000000
6900000000
69 xxx xxxxx
0030 69xxxxxxxx
+3069xxxxxxxx
69/xxxx/xxxx`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);