$re = '`(?:\+|00)?(?:30)?(69\d{8})`m';
$str = 'The mobile phone format i want to extract is 69xxxxxxxx
The mobile phone formats i come across in the CVs are:
6900000000
00306900000000
+306900000000
6900000000
69 xxx xxxxx
0030 69xxxxxxxx
+3069xxxxxxxx
69/xxxx/xxxx';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;