use strict;
my $str = 'The mobile phone format i want to extract is 69xxxxxxxx
The mobile phone formats i come across in the CVs are:
6900000000
00306900000000
+306900000000
6900000000
69 xxx xxxxx
0030 69xxxxxxxx
+3069xxxxxxxx
69/xxxx/xxxx';
my $regex = qr`(?:\+|00)?(?:30)?(69\d{8})`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";