import Foundation
let pattern = #"(?:\+|00)?(?:30)?(69\d{8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The mobile phone format i want to extract is 69xxxxxxxx
The mobile phone formats i come across in the CVs are:
6900000000
00306900000000
+306900000000
6900000000
69 xxx xxxxx
0030 69xxxxxxxx
+3069xxxxxxxx
69/xxxx/xxxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)