# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\+|00)?(?:30)?(69\d{8})"
test_str = ("The mobile phone format i want to extract is 69xxxxxxxx\n"
"The mobile phone formats i come across in the CVs are:\n"
"6900000000\n"
"00306900000000\n"
"+306900000000\n"
"6900000000\n"
"69 xxx xxxxx\n"
"0030 69xxxxxxxx\n"
"+3069xxxxxxxx\n"
"69/xxxx/xxxx")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.