#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[a-z0-9] *){3,}(?:\+ *(?:[a-z0-9] *){3,})*$"
Local $sString = "sss" & @CRLF & _
"sdfsgdf" & @CRLF & _
"4534534" & @CRLF & _
"dfs34543" & @CRLF & _
"sdafds+3232+sfdsafd" & @CRLF & _
"qwe+sdf" & @CRLF & _
"234+567" & @CRLF & _
"cvb+243" & @CRLF & _
"" & @CRLF & _
"jc + fjewif + fjeie" & @CRLF & _
"jc f+ fjewif + fjeie" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"aa" & @CRLF & _
"a+" & @CRLF & _
"aa+" & @CRLF & _
"+aa" & @CRLF & _
"+a" & @CRLF & _
"a+a" & @CRLF & _
"aa+aa" & @CRLF & _
"aaa+a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")