import re
regex = re.compile(r"^(?:[a-z0-9] *){3,}(?:\+ *(?:[a-z0-9] *){3,})*$", flags=re.MULTILINE)
test_str = ("sss\n"
"sdfsgdf\n"
"4534534\n"
"dfs34543\n"
"sdafds+3232+sfdsafd\n"
"qwe+sdf\n"
"234+567\n"
"cvb+243\n\n"
"jc + fjewif + fjeie\n"
"jc f+ fjewif + fjeie\n\n"
"a\n"
"aa\n"
"a+\n"
"aa+\n"
"+aa\n"
"+a\n"
"a+a\n"
"aa+aa\n"
"aaa+a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")