// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[a-z0-9] *){3,}(?:\+ *(?:[a-z0-9] *){3,})*$").unwrap();
let string = "sss
sdfsgdf
4534534
dfs34543
sdafds+3232+sfdsafd
qwe+sdf
234+567
cvb+243
jc + fjewif + fjeie
jc f+ fjewif + fjeie
a
aa
a+
aa+
+aa
+a
a+a
aa+aa
aaa+a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}