const regex = /^(?:[a-z0-9] *){3,}(?:\+ *(?:[a-z0-9] *){3,})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-z0-9] *){3,}(?:\\+ *(?:[a-z0-9] *){3,})*$', 'gm')
const str = `sss
sdfsgdf
4534534
dfs34543
sdafds+3232+sfdsafd
qwe+sdf
234+567
cvb+243
jc + fjewif + fjeie
jc f+ fjewif + fjeie
a
aa
a+
aa+
+aa
+a
a+a
aa+aa
aaa+a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}