use strict;
my $str = 'sss
sdfsgdf
4534534
dfs34543
sdafds+3232+sfdsafd
qwe+sdf
234+567
cvb+243
jc + fjewif + fjeie
jc f+ fjewif + fjeie
a
aa
a+
aa+
+aa
+a
a+a
aa+aa
aaa+a';
my $regex = qr/^(?:[a-z0-9] *){3,}(?:\+ *(?:[a-z0-9] *){3,})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}