using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-z0-9] *){3,}(?:\+ *(?:[a-z0-9] *){3,})*$";
string input = @"sss
sdfsgdf
4534534
dfs34543
sdafds+3232+sfdsafd
qwe+sdf
234+567
cvb+243
jc + fjewif + fjeie
jc f+ fjewif + fjeie
a
aa
a+
aa+
+aa
+a
a+a
aa+aa
aaa+a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}