package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-z0-9] *){3,}(?:\+ *(?:[a-z0-9] *){3,})*$`)
var str = `sss
sdfsgdf
4534534
dfs34543
sdafds+3232+sfdsafd
qwe+sdf
234+567
cvb+243
jc + fjewif + fjeie
jc f+ fjewif + fjeie
a
aa
a+
aa+
+aa
+a
a+a
aa+aa
aaa+a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}